Guidance
指路人
g.yi.org
Guidance Forums / wxWidgets (wxWindows) in C++ / Working with wxGLCanvas

Register 
注册
Search 搜索
首页 
Home Home
Software
Upload

  
Forum List • Thread List • Reply • Refresh • New Topic • Search • Previous • Next First 1 Last
Message1. Working with wxGLCanvas
#4624
Posted by: 2004-06-25 16:38:35
Hi,
I get this error when compiling a program:
 
[Linker error] undefined reference to `wxGLCanvas::wxGLCanvas(wxWindow*, int, wxPoint const&, wxSize const&, long, wxString const&, int*, wxPalette const&)'

can somebosy help me, thank in advanced.
Message2. Re: Working with wxGLCanvas
#4625
Posted by: upCASE 2004-06-25 17:03:12
Hi!
For version 2.5.1 you'll have to link libwxmsw25_gl.a in.
Are you sure that you compiled your wxWidgets library with OpenGl support? It is turned off by default...
upCASE
-----------------------------------
If it was hard to write, it should be hard to read!- Do. Or do not. There is no try!
Message3. Re: Working with wxGLCanvas
#4626
Posted by: 2004-06-25 18:37:02
I'm working with Dev++ 4.9.8.0 and wxWindows package 2.4.2. I have assigned  wxUSE_GLCANVAS=1 in both files: wx/setup.h and /wx/msw/setup.h. The proyect options for linker are set to:

-Wl,--subsystem,windows -mwindows -lwxmsw -lstdc++ -lgcc -lodbc32 -lwsock32 -lwinspool -lwinmm -lshell32 -lcomctl32 -lctl3d32 -ladvapi32 -lopengl32 -lglu32 -lole32 -loleaut32 -luuid 

The error persists.

Jesús.
Message4. Re: Working with wxGLCanvas
#4627
Posted by: 2004-06-25 18:51:48
Thank you for answering me. I'm working with Dev++ 4.9.8.0 and wxWindows package 2.4.2. I have assigned  wxUSE_GLCANVAS=1 in both files: wx/setup.h and /wx/msw/setup.h. The proyect options for linker are set to:

-Wl,--subsystem,windows -mwindows -lwxmsw -lstdc++ -lgcc -lodbc32 -lwsock32 -lwinspool -lwinmm -lshell32 -lcomctl32 -lctl3d32 -ladvapi32 -lopengl32 -lglu32 -lole32 -loleaut32 -luuid 

The error persists.

Jesús.
Message5. Re: Working with wxGLCanvas
#4628
Posted by: upCASE 2004-06-25 19:11:10
Hi!
Ok, so you set wxUSE_GLCANVAS=1. Did you only set it, or was it set when you compiled the library?
Problem is: Just setting wxUSE_GLCANVAS to 1 will make the errors about not finding the wxGLCanvas class go away, but the object files which implement the class will be missing in the library.
Two pssible ways:
1. Set wxUSE_GLCANVAS=1 and recompile the library. Hopefully you didn't do a "make clean" :)
2. Set wxUSE_GLCANVAS=1 and compile only the needed files for OpenGL (I suppose glcanvas.cpp is the only file you need). Either add glcanvas.cpp/glcanvas.o to your project or use "ar" and add it to the library.
upCASE
-----------------------------------
If it was hard to write, it should be hard to read!- Do. Or do not. There is no try!
Forum List • Thread List • Reply • Refresh • New Topic • Search • Previous • Next First 1 Last
掌柜推荐
 
 
 
 
 
 
 
 
 
 
 
 
© Mon 2022-8-15  Guidance Laboratory Inc.
Email:webmaster1g.yi.org Hits:0