Guidance
指路人
g.yi.org
Guidance Forums / wxWidgets (wxWindows) in C++ / Error when compiling - "multiple definitions.."

Register 
注册
Search 搜索
首页 
Home Home
Software
Upload

  
Forum List • Thread List • Reply • Refresh • New Topic • Search • Previous • Next First 1 Last
Message1. Error when compiling - "multiple definitions.."
#5438
Posted by: 2004-11-21 06:19:46
  I have dev-cpp 4.9.8.1, and the folowing packages:
  Image Libraries 1
  WxWindows Development Kit 2.4.2
  WxWindows Contribs 2.4.2

  So, when i compile that sample that appears when I begin a wxwindows application, the compiler gives this erros:
  frame.cpp - multiple definition of 'vtable for wxFrame"
  main.cpp - first defined here

  A lot of this error.. only changing wxFrane for other classes
  The project has only one  file (main.cpp) .. like I sad, it?s that example that begins when I create a wxwindows application..

  Someone know how to fix it??

 Sorry for my english....
Message2. Re: Yes, I have the same problem!
#5525
Posted by: 2004-12-04 05:15:59
I have the same exact problem. I have no clue whatsoever to what's causing this error. Can anyone help please?
Message3. Re: Yes, I have the same problem!
#5527
Posted by: guidance 2004-12-04 09:52:43
Try this options:
http://g.yi.org/f.php?f=14289
Message4. Re: Yes, I have the same problem!
#5560
Posted by: 2004-12-08 04:56:01
I had the same problem as you.  I'm running Dev-C++.  Here was my scenario though.  I had previously installed wxWindows 2.2.9 and then 2.4.2.  Once I installed one on top of the other, I kept getting multiple definitons for 'vtable'.  What worked for me was to remove the wxWindows package completely and re-install the latter (2.4.2 and I have even gone further by installing 2.5.3 after removing 2.4.2).

So, my advice is to de-install the wxWindows dev-pak and re-install it.

Hope this helps...
Message5. Re: Yes, I have the same problem!
#5601
Posted by: 2004-12-15 03:57:38
I've done some experimenting with this.  And, have definitely been able to reproduce the error by not de-installing on the wxWindows DevPak before installing an update.

The problem also occurs if you install an earlier contrib pak after installing wxWindows.  So, if I install wxWindows 2.4.2 and then install wxWindows.contrib 2.4.0, the problem occurs.

Once I remove both wxWindows and wxWindows contrib pak and reinstall wxWindows, everything compiles fine.
Forum List • Thread List • Reply • Refresh • New Topic • Search • Previous • Next First 1 Last
掌柜推荐
 
 
 
 
 
 
 
 
 
 
 
 
© Mon 2022-8-8  Guidance Laboratory Inc.
Email:webmaster1g.yi.org Hits:0